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NDSTM eDirectory TM is a highly scalable, high-performing, secure directory service. It can 
store and manage a billion Directory objects. NDS natively supports the directory standard 
LDAP v3 over Secure Socket Layer (SSL). 

For more information, see Product Information (www.novell.com/products/nds), Product 
Support (support.novell.com), Online Forums (news://forums.novell.com), Product, Catalog 
(www.novell.com/catalog), or Product Documentation (www.novell.com/documentation).

3URGXFW�)HDWXUHV

NDS offers the following features:

Some of these features provide improvements over previous versions of Novell Directory 
ServicesTM.

w Increased NDS capacity 

w Increased performance for Directory reads, writes, and searches

w ConsoleOneTM management 

w Increased Lightweight Directory Access Protocol (LDAP) v3 performance

w Improved DSREPAIR utility (or ndsrepair on Solaris) 

w BULKLOAD utility for adding, modifying, and deleting NDS objects in a batch process (or 
ndsbulkload on Solaris) 

w Extended naming support, including “dc=” naming and unique ID 

1'6�'$7$�6758&785(

NDS uses a highly-scalable, indexed database instead of the fixed- length record data store 
used by earlier NDS versions. Instead of using TTS, NDS uses log files to back out and roll 
forward transactions in the event of a system failure.
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w ConsoleOne

Use ConsoleOne to configure SSL for LDAP and to manage very large NDS trees 
across multiple platforms.

w NetWare Administrator 

Use NetWare Administrato to manage small and medium NDS trees across multiple 
platforms.

w NDS Manager

Use NDS ManagerTM (NDSMGR32.EXE) included with NetWare® 5 to manage 
partitions and replicas.

%8/./2$'

You can use the BULKLOAD utility to create, modify, and delete NDS objects in a 
batch process. The BULKLOAD utility uses LDAP Data Interchange Format (LDIF) 
files for batch processing, which can be generated from most e-mail programs.

'65(3$,5

The DSREPAIR utility is enhanced to work with the NDS across multiple platforms. 
The DSREPAIR utility can:

w Perform structure checks of the database automatically without closing the database 
and without user intervention. 

w Perform index checks. 

w Repair the database without closing the database or locking out users.

w Reclaim free space by discarding empty records.

/'$3�6HUYLFHV

Novell’s implementation of LDAP is LDAP v3 compliant. It includes the following 
features in this release:

w Complete management through the ConsoleOne utility

w Tighter integration with NDS 

w Enhanced search capabilities with a Referral option
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NDS offers the following enhancements to schema management:

w You can use ConsoleOne to manage the schema.

w ASN1 IDs uniquely identify each attribute and class in the schema.

w The Domain class (a container class) is added to the schema.

w You can create auxiliary classes so that applications can associate a set of properties 
with specific objects rather than an entire class of objects.

3URGXFW�/LPLWDWLRQV

w There is no print option or print management from ConsoleOne.

w When searching NDS across replicas on multiple servers, the search results might 
not be properly sorted.

w Object sorting in non-English environments might not work properly.

w Schema Manager does not generate schema reports. 

You can use Schema Manager in NDS Manager to generate schema reports. 

w DSMERGE.NLM won’t work on a server running NDS. 

You can use DSMERGE.NLM from another server if you have performed all schema 
enhancements on both trees.

,QVWDOOLQJ�1'6�H'LUHFWRU\

1'6�5816�21�7+(�)2//2:,1*�3/$7)2506�

w NetWare

w Windows* NT*

w Solaris

Also refer to the readme files at the root of each product platform directory for 
complete installation instructions.
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� Save all server information before installing the software.

� Download the files used in the installation.

� If necessary, perform and test any hardware upgrades prior to installing NDS. 

� Ensure that DSREPAIR is updated.

� Update the tree’s schema. 

This step is conditional, depending on where NDS is installed first.

(QDEOLQJ�6HFXUH�/'$3�&RQQHFWLRQV

Although this procedure demonstrates how to perform the task in ConsoleOne, NetWare 
Administrator can perform the same task.

� In ConsoleOne, right-click the Security object at the [Root] of the tree and click New 
> Object.

� Click NDSPKI: Certificate Authority > OK, then follow the online instructions. 

� Right-click the LDAP Server container, then click New > Object. 

� Click NDSPKI: Key Material > OK, then follow the online instructions.

� Expand the LDAP Server container.

� Right-click the Key Material object you created for the SSL certificate, then click 
Refresh LDAP Server Now > Close.

� Export the self-assigned CA from NDS.

�D Right click the Key Material Object.

�E Select Properties.

�F Choose Trusted Root Certificate under the Certificates tab.

�G Select Export.

� Install the self assigned CA in all browsers that establish secure LDAP connections 
to NDS.

This procedure allows you to import the trusted root into the browser.
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To import the trusted root into Netscape* Navigator:

� Click File > Open Page > Choose File.

� Open the trusted root file exported in Step 4 of “Enabling Secure LDAP Connections.” 

This launches the New Certificate Authority wizard. 

� Follow the online prompts, then check the box labeled “Accept this Certificate 
Authority for Certifying Network Sites.”

The New Certificate Authority wizard does not display if you do not have the correct 
file extension registered on your workstation. This is typically the case if you installed 
Internet Explorer 5 and/or Windows NT Service Pack 4 or greater.

To fix this problem:

�D Exit Navigator and run the file x509.REG (located in <Install_dir>\NDS\x509.reg 
on Windows NT, SYS\:PUBLIC on NetWare, and the Windows directory on the 
product CD). 

�E Rename the trusted root certificate file you exported to .x509 extension, then 
import the certificate into Navigator.

To import the trusted root into Internet Explorer: 

� Click File > Open > Browse. 

� Locate and select the trusted root file exported in Step 4 of “Enabling Secure LDAP 
Connections.” 

Complete the New Site Certificate wizard to install the trusted root into Internet 
Explorer.
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q NetWare 5 server.

q NetWare 5 Support Pack 2 or later.

q Administrative rights to [Root] to modify the schema.

q ConsoleOneTM administrator workstation with a 200 MHz processor or faster and a min-
imum of 64 MB of RAM. 

The workstation must be running the NetWare 5 (or newer) Novell® ClientTM software 
before executing the ConsoleOne SETUP.EXE.

q The Novell Cryptography Support Modules (NICI 1.3 or later) downloaded from
http://www.novell.com/products/cryptography if you need ephemeral key support for 
SSL connections.

3UHSDULQJ�WR�,QVWDOO�RQ�1HW:DUH

w If you are upgrading your hardware in conjunction with the NDSTM upgrade, install the 
new hardware and test it with the existing network operating system and NDSTM version 
before upgrading to NDS eDirectoryTM. This allows you to isolate any problems to the 
appropriate cause.

w Run the appropriate DSREPAIR.NLM.

w If your first installation of NDS is on a NetWare 5 server holding a replica of the 
[Root] partition, you don’t need to run DSREPAIR.

w If you are upgrading from NDS 8 to NDS eDirectoryTM, you must first run 
DSREPAIR.NLM (version 6.31).

w If your first installation of NDS is on a NetWare 5 server that does not hold a replica 
of [Root], you must first run the appropriate DSREPAIR version on the server 
holding a replica of [Root]. 
160-000233-001 A
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� From the product download page, click the link to the Readme File, and download the 
appropriate version of DSREPAIR from the NDS 8 Quick Reference Page.

Different versions of DSREPAIR are available. Run the version of DSREPAIR that 
corresponds to the version of NetWare or NDS you are upgrading.

� After locating and downloading the appropriate DSREPAIR from the product 
download page, copy the appropriate DSREPAIR.NLM to the SYS:SYSTEM directory 
of your server. 

� At the server console, run DSREPAIR and select Advanced Options Menu > Global 
Schema Operations > Post NetWare 5 Schema Update.

� Enter the Admin name (example:.Admin.Company) and password. 

� Modify the server AUTOEXEC.NCF file.

w If you install NDS using RCONSOLE, include the following commands in the server’s 
AUTOEXEC.NCF file:

REMOTE [password]

RSPX

w If you install NDS using the Java-Based Remote Console, include the following 
commands in the AUTOEXEC.NCF file:

SPXS

SPXSRCONAG6 [password] [TCP port] [SPX port]

,QVWDOOLQJ�1'6�H'LUHFWRU\�RQ�1HW:DUH

To install NDS, you need to do the following:

q Install Support Pack 2

q Install NDS

,167$//,1*�6833257�3$&.��

� Download and expand the Support Pack 2 or later software from support.novell.com/
products/nw5/patches.htm to a directory on the NetWare 5 server.

� At the server console, start NWCONFIG.NLM.

� Select Product Options > Install a Product Not Listed. 
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� Press F3 (F4 if you’re using RCONSOLE) and specify the path to the expanded 
Support Pack 2 files.

� Follow the online instructions to install the Support Pack. 

� Reboot the server.

,167$//,1*�1'6

� Download and expand the NDS from www.novell.com/download/ to a single directory 
on the NetWare 5 server.

� At the server console, start NWCONFIG.NLM again.

� Click Product Options > Install a Product Not Listed.

� Press F3 (F4 if you’re using RCONSOLE), and specify the path to the NDS files. 

When the files are copied, the server automatically reboots.

� Make sure all volumes are mounted. 

If you’re not sure whether all volumes are mounted, run the following command at the 
server console:

MOUNT ALL

� Switch to the NWConfig screen by pressing Ctrl+Esc, then select the number 
corresponding to the screen.

� Enter the administrator’s login name (with context) and password. 

The installation upgrades LDAP. 

� Press Esc to close the upgrade status log.

You are prompted to reboot.

� Click Yes > Restart Now. 

The server reboots, and the NDS upgrade is complete.

Repeat this procedure for each NetWare 5 server you want to upgrade to NDS. If you do 
not configure LDAP for SSL, you receive an error message.
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By default, NDS uses 8 MB of RAM for cache. This setting allows NDS to run on servers 
without requiring more RAM. If you have sufficient RAM to increase the NDS and 
BULKLOAD cache size, you can significantly increase the efficiency of NDS for large 
databases by allocating more RAM to the NDS cache.

To set the cache size, use the following command at the server console:

SET DSTRACE = !mb[bytes]

The smallest tested cache size is 0 and the largest is 2 GB. NDS runs with either amount.

/RDGLQJ�'LUHFWRU\�2EMHFWV�IURP�/',)�)LOHV�RQ�1HW:DUH

Use BULKLOAD to create, modify, or delete NDS objects in a batch process. 

BULKLOAD uses LDIF files for batch processing.

BULKLOAD can produce keypairs for each user when the user Password field is 
included. (The process runs considerably slower when you include the user Password 
field.)

To use BULKLOAD, you must first create your LDIF file. After you create the LDIF file, 
follow the steps below:

� Copy the LDIF file to the SYS:SYSTEM directory of a server running NDS.

� At the server console, start BULKLOAD.NLM.

� When prompted, log in as a user with the NDS rights needed to perform the 
operations (add, delete, or modify objects and properties).

� Select Apply LDIF File to run the batch process.
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NDS does not automatically provide LDAP support for a Domain object to contain other 
container objects. To enable this functionality, before or after installing NDS, complete the 
following steps:

� Ensure that replica-holding 4.x servers have the latest version of NDS:

w NetWare 4.11 must have NDS version 602 or later.

w NetWare 4.10 must have NDS version 517 or later.

Earlier versions of NDS receive schema changes properly but do not propagate 
them to child replicas.

� Copy the appropriate version of DSREPAIR to the SYS:SYSTEM directory of a server 
holding a replica of the [Root] partition.

w For a NetWare 4.10 or 4.11 server, copy DSREPAIR.NLM from \DSREPAIR\4X.

w For a NetWare 5 server, copy DSREPAIR.NLM from \DSREPAIR\5X.

w For a server running NDS, use DSREPAIR.NLM installed automatically with the 
update.

� From the server console, run DSREPAIR and select Advanced Options Menu > 
Global Schema Operations > Optional Schema Enhancements.
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NDSTM on Windows NT does not require a NetWare server to perform to full capacity.

q NT server 4.0 with Service Pack 3 or higher and an assigned IP address.

q Pentium 200 with 64 MB RAM and a monitor color palette set to a number higher than 
16.

q Administrative rights to the NT server and to all portions of the NDS tree that contain 
domain-enabled User objects. For the first NDS installation, you need administrative 
rights to the root of the tree to extend the schema.

q A supported version of NetWare, only if used in a mixed NetWare/NT environment.

w NetWare 4.11 server with Support Pack 6 or higher. The NDSTM version of NetWare 
4.11 servers must be 5.99a or later.

w NetWare 4.2.

w NetWare 5 with Support Pack 2.

q Workstations running Novell Client™ for Windows 95 3.0 or higher or Novell Client for 
Windows NT 4.5 or higher.
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To install NDS eDirectoryTM into an existing NDS tree, a copy of DSREPAIR provided on 
the CD must be run on the server containing the master of the [ROOT] replica. Depending 
on the version of NetWare and NDS, the following versions of DSREPAIR must be run:

w NetWare 5: /PATCHES/NETWARE/NW5X/DSREPAIR.NLM

w NetWare 4.11: /PATCHES/NETWARE/NW4X/DSREPAIR.NLM

w NDS 8: /PATCHES/NETWARE/NDS6/DSREPAIR.NLM

� Copy the appropriate DSREPAIR.NLM onto your server.

� At the server console, run DSREPAIR, and select Advanced Options Menu > Global 
Schema Operations > Post NetWare 5 Schema Update. 

� Enter the Admin name (example: .Admin.Company) and password.

,QVWDOOLQJ�1'6�H'LUHFWRU\�RQ�:LQGRZV�17

Click Help for detailed information on each installation screen and for help in using NDS.

� At the NT server, log on as Administrator or as a user with administrative privileges.

� Run SETUP.EXE from the downloaded file.

� Select which components to install.

You can install the components separately or together. The following instructions 
describe how to install the components separately. If you install them together, all 
installations are completed.

w Install Novell Directory Services

Installs NDS in an NT-only or mixed NT/NetWare server environment. See 
“Installing Novell Directory Services.”

w Install NDS Management Utilities

Installs NetWare Administrator, NDS ManagerTM, and ConsoleOneTM. See 
“Installing NDS Management Utilities.”
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� Follow the online instructions in the Installation Wizard.

You can install Novell Directory Services into the existing tree or create a new tree.

This installation requires the licensing diskette.

� When prompted, reboot the server. 

If you select only Installing Novell Directory Services as a component, the Domain 
Object Wizard, which integrates NT Domains into NDS, does not appear.

,167$//,1*�1'6�0$1$*(0(17�87,/,7,(6

After running SETUP.EXE, select Installing Management Utilities. This installs NDS 
management utilities, including ConsoleOne, NDS Manager, and NetWare Administrator, 
and creates a Share called SYS: on the NT server.
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w Solaris* 2.6 or Solaris 7 (SPARC* platform edition).

w A minimum of 64 MB of RAM. To run the NDS server and LDAP server a minimum of 
128 MB RAM is recommended.

w 21 MB of disk space to install the NDS server (including LDAP server and Novell Public 
Key Cryptography Services). Add 35 KB of disk space per 100 certificates and 3 MB per 
1000 NDSTM User objects in the replica.

w Windows* 95/98 or Windows NT* workstation with 64 MB of RAM and 125 MB of disk 
space.

w Novell® ClientTM for Windows 95/98 version 3 or higher, or Windows NT version 4.5 or 
higher.

3UHSDULQJ�WR�,QVWDOO

w Install the latest recommended Solaris 2.6 and Solaris 7 patches, till 1st September 
1999. The patches are available at http:\\access1.sun.com.

w Enable the Solaris host, on which you are installing the product, for multicast routing.

w The time on all the servers in the network should be synchronized. Use Network Time 
Protocol (NTP) to synchronize time. Refer to xntpd(1M) for more information. If you want 
the synchronize time on Solaris servers with Netware servers, use TIMESYNC.NLM 
version 5.09 or above.
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w To install NDS eDirectory into an existing NetWare NDS tree, run DSREPAIR on the 
server containing the master replica of the root partition from the CD. 

On NetWare 5, run DSREPAIR from the /PATCHES/NETWARE/NW5X directory on 
the CD. 

On NDS, run DSREPAIR from the /PATCHES/NETWARE/NDS8 directory on the CD. 

Copy the appropriate DSREPAIR.NLM to the SYS:SYSTEM directory of your server. 
At the server console, run DSREPAIR and select Advanced Options > Global Schema 
operations > Post NetWare 5 Schema Update.

w All the replicas in the partition, into which you installing the product, should be in the 
ON state. This can verified using NDS Manager.

w For the first NDS installation, the administrator should have Write access to the [Root] 
of the tree. 

w If there is a NetWare system in the network in which you are installing the product, 
verify that the SLP DA’s are stable. Enter the command display slp da, at the 
NetWare server console, to view the status of the SLP DA (active or inactive).

NOTE: Please refer the Administrator’s guide on the CD for more information.

,QVWDOOLQJ�1'6�H'LUHFWRU\�RQ�6RODULV

To install NDS on Solaris systems, you need to do the following:

w Run the Solaris installation program

w Install NDS Management Utilities

After completing the installation on the Solaris host, you need to run the Setup 
program on the Windows workstation that is going to be used for administration. This 
program installs ConsoleOne and the NDS administration utilities.
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� On the SPARC Solaris system, log in as root.

� Insert the product CD.

� Change to the Solaris directory on the CD and run nds-install.

� Choose to install the NDS Server. 

The installation program proceeds to add various packages of the NDS Server 
component.

� If the Install program cannot locate the NICI foundation Key file in the default locations 
(/opt/nds and the license diskette), you are prompted to enter the complete path to the 
NICI foundation Key file.

You are prompted if the path entered is not valid or the file cannot be located. If you 
skip the installation, you will not be able to create certificates.

� The program asks for configuration information. Though you can configure the 
product later using ndscfg, we recommend that you configure now to ensure proper 
functioning of the product.

� Enter the following configuration parameters in the ndscfg.inp file, which is opened in 
the default editor:

w Name (with full context) of the user with administration rights to the root of the 
tree

w Tree name

w Server context

w (Optional) DB files dir

� (Optional) To install NDS in a new tree, specify the value “Yes” for the Create NDS 
Tree parameter.

� (Optional) To install LDAP Services for NDS, specify the value “Yes” for the Install 
LDAP Services parameter.

Enter a name with full context (for example, 
cn=yourldapgroup.ou=yourcontainer.o=yourorganization) for the LDAP Group object. 
To create this object, specify the value “Yes” for the Create LDAP Group object 
parameter. If the specified context does not exist, the default LDAP Group object 
(LDAP Group <servername>) is created in the context where the server is located.

�� Save the information and close the editor.

�� Enter the password of the user with administration rights, when prompted.
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You can install the Windows component either on Windows 95/98 or NT workstation.

� Insert the product CD.

� Run WINSETUP.EXE from the Windows directory on the CD.

� Install ConsoleOneTM and NDS administration utilities. Select the desired option.

w ConsoleOne - This option installs the ConsoleOne utility and copies the NDS-SE 
PKI and LDAP snap-ins.

w Install NDS Administration Utilities - This option installs NDS ManagerTM and 
NetWare Administrator.

� Follow the instructions given in the Setup program.

� (Optional) To install the Client DLL, run SETUP.EXE in the Install directory on the 
Windows system into which you have installed ConsoleOne.

NOTE: Using the Windows 95/98 or NT workstation, these NDS utilities can be installed 
on a NetWare volume also.
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